using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<([\w_-]*)>.*?<(\/\1)>";
string input = @"irgend ein Text
der überlesen wird
<determination>
<title>Sport-Radfahren
</title>
<date>20.04.2022
</date>
<abstract>Da findet (vielleicht) der R(h)einflach statt.
</abstract>
</determination>
und zwischen 2 XML Fragmenten wieder Text.
und noch ein wenig
<detMin1-2>
<title>Sport-Schwimmen
</title>
<date>01.05.2022
</date>
<abstract>Eröffnung der Freischwimm Saison im Lambsheimer Weiher?
</abstract>
</detMin1-2>
und auch text danach
blablabla
";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}