$re = '/<([\w_-]*)>.*?<(\/\1)>/s';
$str = 'irgend ein Text
der überlesen wird
<determination>
<title>Sport-Radfahren
</title>
<date>20.04.2022
</date>
<abstract>Da findet (vielleicht) der R(h)einflach statt.
</abstract>
</determination>
und zwischen 2 XML Fragmenten wieder Text.
und noch ein wenig
<detMin1-2>
<title>Sport-Schwimmen
</title>
<date>01.05.2022
</date>
<abstract>Eröffnung der Freischwimm Saison im Lambsheimer Weiher?
</abstract>
</detMin1-2>
und auch text danach
blablabla
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);