import Foundation
let pattern = #"<([\w_-]*)>.*?<(\/\1)>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
irgend ein Text
der überlesen wird
<determination>
<title>Sport-Radfahren
</title>
<date>20.04.2022
</date>
<abstract>Da findet (vielleicht) der R(h)einflach statt.
</abstract>
</determination>
und zwischen 2 XML Fragmenten wieder Text.
und noch ein wenig
<detMin1-2>
<title>Sport-Schwimmen
</title>
<date>01.05.2022
</date>
<abstract>Eröffnung der Freischwimm Saison im Lambsheimer Weiher?
</abstract>
</detMin1-2>
und auch text danach
blablabla
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)