use strict;
my $str = 'irgend ein Text
der überlesen wird
<determination>
<title>Sport-Radfahren
</title>
<date>20.04.2022
</date>
<abstract>Da findet (vielleicht) der R(h)einflach statt.
</abstract>
</determination>
und zwischen 2 XML Fragmenten wieder Text.
und noch ein wenig
<detMin1-2>
<title>Sport-Schwimmen
</title>
<date>01.05.2022
</date>
<abstract>Eröffnung der Freischwimm Saison im Lambsheimer Weiher?
</abstract>
</detMin1-2>
und auch text danach
blablabla
';
my $regex = qr/<([\w_-]*)>.*?<(\/\1)>/sp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}