#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d+(?=,\d*\s*CZK)"
Local $sString = "Date: Sat, 13 Jun 2015 13:26:05 +0100" & @CRLF & _
"Subject: Changing the balance: +50,00 CZK" & @CRLF & _
"Dear client," & @CRLF & _
"" & @CRLF & _
"Date: Sat, 14 Jun 2015 14:58:05 +0100" & @CRLF & _
"Subject: Changing the balance: +75,00 CZK" & @CRLF & _
"Dear client,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")