import re
regex = re.compile(r"\d+(?=,\d*\s*CZK)", flags=re.MULTILINE)
test_str = ("Date: Sat, 13 Jun 2015 13:26:05 +0100\n"
"Subject: Changing the balance: +50,00 CZK\n"
"Dear client,\n\n"
"Date: Sat, 14 Jun 2015 14:58:05 +0100\n"
"Subject: Changing the balance: +75,00 CZK\n"
"Dear client,")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")