import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+(?=,\\d*\\s*CZK)";
final String string = "Date: Sat, 13 Jun 2015 13:26:05 +0100\n"
+ "Subject: Changing the balance: +50,00 CZK\n"
+ "Dear client,\n\n"
+ "Date: Sat, 14 Jun 2015 14:58:05 +0100\n"
+ "Subject: Changing the balance: +75,00 CZK\n"
+ "Dear client,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}