re = /\d+(?=,\d*\s*CZK)/m
str = 'Date: Sat, 13 Jun 2015 13:26:05 +0100
Subject: Changing the balance: +50,00 CZK
Dear client,
Date: Sat, 14 Jun 2015 14:58:05 +0100
Subject: Changing the balance: +75,00 CZK
Dear client,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end