use strict;
my $str = '31-07-2005';
my $regex = qr/^(31-(0[13578]|1[02])-(18|19|20)[0-9]{2})|((29|30)-(01|0[3-9]|1[1-2])-(18|19|20)[0-9]{2})|((0[1-9]|1[0-9]|2[0-8])-(0[1-9]|1[0-2])-(18|19|20)[0-9]{2})|(29-(02)-(((18|19|20)(04|08|[2468][048]|[13579][26]))|2000))$/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}