// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(31-(0[13578]|1[02])-(18|19|20)[0-9]{2})|((29|30)-(01|0[3-9]|1[1-2])-(18|19|20)[0-9]{2})|((0[1-9]|1[0-9]|2[0-8])-(0[1-9]|1[0-2])-(18|19|20)[0-9]{2})|(29-(02)-(((18|19|20)(04|08|[2468][048]|[13579][26]))|2000))$").unwrap();
let string = "31-07-2005";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}