import re
regex = re.compile(r"^(31-(0[13578]|1[02])-(18|19|20)[0-9]{2})|((29|30)-(01|0[3-9]|1[1-2])-(18|19|20)[0-9]{2})|((0[1-9]|1[0-9]|2[0-8])-(0[1-9]|1[0-2])-(18|19|20)[0-9]{2})|(29-(02)-(((18|19|20)(04|08|[2468][048]|[13579][26]))|2000))$")
test_str = "31-07-2005"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")