re = /^(31-(0[13578]|1[02])-(18|19|20)[0-9]{2})|((29|30)-(01|0[3-9]|1[1-2])-(18|19|20)[0-9]{2})|((0[1-9]|1[0-9]|2[0-8])-(0[1-9]|1[0-2])-(18|19|20)[0-9]{2})|(29-(02)-(((18|19|20)(04|08|[2468][048]|[13579][26]))|2000))$/
str = '31-07-2005'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end