#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "/(?<=foo)bar/"
Local $sString = "foobar"
Local $sSubst = "fuu"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)