use strict;
my $str = 'foobar';
my $regex = qr//(?<=foo)bar//p;
my $subst = 'fuu';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";