import Foundation
let pattern = #"/(?<=foo)bar/"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"foobar"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"fuu"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)