const regex = new RegExp('/(?<=foo)bar/', 'g')
const str = `foobar`;
const subst = `fuu`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);