using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{3}-\d{3}";
string input = @"+1-703-535-1039 +1-703-728-8382 +1-703-638-1039 +1-703-535-1039 ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}