re = /\d{3}-\d{3}/
str = '+1-703-535-1039 +1-703-728-8382 +1-703-638-1039 +1-703-535-1039 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end