import re
regex = re.compile(r"\d{3}-\d{3}")
test_str = "+1-703-535-1039 +1-703-728-8382 +1-703-638-1039 +1-703-535-1039 "
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")