package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{3}-\d{3}`)
var str = `+1-703-535-1039 +1-703-728-8382 +1-703-638-1039 +1-703-535-1039 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}