using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*<Target Name=""(EnsureNuGetPackageBuildImports|EnsureBclBuildImported)"".*?(?=>)(.|\n)*?<\/Target>";
string input = @"<Target Name=""EnsureBclBuildImported"">
Some Stuff Here
</Target>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}