$re = '/\s*<Target Name=""(EnsureNuGetPackageBuildImports|EnsureBclBuildImported)"".*?(?=>)(.|\n)*?<\/Target>/';
$str = '<Target Name=""EnsureBclBuildImported"">
Some Stuff Here
</Target>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);