re = /\s*<Target Name=""(EnsureNuGetPackageBuildImports|EnsureBclBuildImported)"".*?(?=>)(.|\n)*?<\/Target>/
str = '<Target Name=""EnsureBclBuildImported"">
Some Stuff Here
</Target>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end