const regex = /\s*<Target Name=""(EnsureNuGetPackageBuildImports|EnsureBclBuildImported)"".*?(?=>)(.|\n)*?<\/Target>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*<Target Name=""(EnsureNuGetPackageBuildImports|EnsureBclBuildImported)"".*?(?=>)(.|\\n)*?<\\\/Target>', '')
const str = `<Target Name=""EnsureBclBuildImported"">
Some Stuff Here
</Target>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}