import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?:\\/\\/assets\\.example\\.com\\/images\\/[a-zA-Z0-9]{8,9})m(\\/[a-zA-Z0-9]{8,9}\\.jpg)";
final String string = "http://assets.example.com/images/11233434m/23435436.jpg\n"
+ "http://assets.example.com/images/112aa3434m/23435436.jpg";
final String subst = "$1l$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}