re = /(https?:\/\/assets\.example\.com\/images\/[a-zA-Z0-9]{8,9})m(\/[a-zA-Z0-9]{8,9}\.jpg)/m
str = 'http://assets.example.com/images/11233434m/23435436.jpg
http://assets.example.com/images/112aa3434m/23435436.jpg'
subst = '$1l$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result