import Foundation
let pattern = #"(https?:\/\/assets\.example\.com\/images\/[a-zA-Z0-9]{8,9})m(\/[a-zA-Z0-9]{8,9}\.jpg)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://assets.example.com/images/11233434m/23435436.jpg
http://assets.example.com/images/112aa3434m/23435436.jpg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1l$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)