# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(https?:\/\/assets\.example\.com\/images\/[a-zA-Z0-9]{8,9})m(\/[a-zA-Z0-9]{8,9}\.jpg)"
test_str = ("http://assets.example.com/images/11233434m/23435436.jpg\n"
"http://assets.example.com/images/112aa3434m/23435436.jpg")
subst = "$1l$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.