#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)"shawn_123".*?"id":\s"(\d+)""
Local $sString = "{" & @CRLF & _
""meta": {" & @CRLF & _
""code": 200" & @CRLF & _
"}," & @CRLF & _
""data": [" & @CRLF & _
" {" & @CRLF & _
" "username": "shawn_123"," & @CRLF & _
" "profile_picture": "https://scontent.cdninstagram.com/t51.2885- 19/s150x150/11417456_1610194859266611_592197892_a.jpg"," & @CRLF & _
" "id": "641567093"," & @CRLF & _
" "full_name": "shawn ritz"" & @CRLF & _
"}," & @CRLF & _
" {" & @CRLF & _
" "username": "shawn_12345"," & @CRLF & _
" "profile_picture": "https://scontent.cdninstagram.com/t51.2885-19/s150x150/11324946_808347519273018_2073555780_a.jpg"," & @CRLF & _
" "id": "2074312361"," & @CRLF & _
" "full_name": "shawney"" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")