$re = '/"shawn_123".*?"id":\s"(\d+)"/s';
$str = '{
"meta": {
"code": 200
},
"data": [
{
"username": "shawn_123",
"profile_picture": "https://scontent.cdninstagram.com/t51.2885- 19/s150x150/11417456_1610194859266611_592197892_a.jpg",
"id": "641567093",
"full_name": "shawn ritz"
},
{
"username": "shawn_12345",
"profile_picture": "https://scontent.cdninstagram.com/t51.2885-19/s150x150/11324946_808347519273018_2073555780_a.jpg",
"id": "2074312361",
"full_name": "shawney"
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);