#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<BG CASE>(.*):\n?(\s+(.*))\n?\s+<BG \/CASE>"
Local $sString = "<BG SWITCH>param" & @CRLF & _
" <BG CASE>value1:" & @CRLF & _
" text 1" & @CRLF & _
" <BG /CASE>" & @CRLF & _
" <BG CASE>value2:" & @CRLF & _
" text 2" & @CRLF & _
" <BG /CASE>" & @CRLF & _
" <BG CASE>value3:" & @CRLF & _
" text 3" & @CRLF & _
" <BG /CASE>" & @CRLF & _
" <BG CASE>value4:" & @CRLF & _
" text 4" & @CRLF & _
" <BG /CASE>" & @CRLF & _
"<BG /SWITCH>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")