package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<BG CASE>(.*):\n?(\s+(.*))\n?\s+<BG \/CASE>`)
var str = `<BG SWITCH>param
<BG CASE>value1:
text 1
<BG /CASE>
<BG CASE>value2:
text 2
<BG /CASE>
<BG CASE>value3:
text 3
<BG /CASE>
<BG CASE>value4:
text 4
<BG /CASE>
<BG /SWITCH>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}