import Foundation
let pattern = #"<BG CASE>(.*):\n?(\s+(.*))\n?\s+<BG \/CASE>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<BG SWITCH>param
<BG CASE>value1:
text 1
<BG /CASE>
<BG CASE>value2:
text 2
<BG /CASE>
<BG CASE>value3:
text 3
<BG /CASE>
<BG CASE>value4:
text 4
<BG /CASE>
<BG /SWITCH>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)