re = /<BG CASE>(.*):\n?(\s+(.*))\n?\s+<BG \/CASE>/m
str = '<BG SWITCH>param
<BG CASE>value1:
text 1
<BG /CASE>
<BG CASE>value2:
text 2
<BG /CASE>
<BG CASE>value3:
text 3
<BG /CASE>
<BG CASE>value4:
text 4
<BG /CASE>
<BG /SWITCH>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end