const regex = /^(?:[a-zA-Z ]+|\d+\.)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[a-zA-Z ]+|\\d+\\.)+$', 'gm')
const str = `Foo foo fooooo 3`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);