use strict;
my $str = 'Foo foo fooooo 3';
my $regex = qr/^(?:[a-zA-Z ]+|\d+\.)+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";