$re = '/^(?:[a-zA-Z ]+|\d+\.)+$/m';
$str = 'Foo foo fooooo 3';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;