package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)[\d]{4}(-|\/)[\d]{2}(-|\/)[\d]{2}`)
var str = `2000-02-02
1987-02-02
1000-sd-65
2100-12-87
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}