re = /[\d]{4}(-|\/)[\d]{2}(-|\/)[\d]{2}/mi
str = '2000-02-02
1987-02-02
1000-sd-65
2100-12-87
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end