// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)[\d]{4}(-|\/)[\d]{2}(-|\/)[\d]{2}").unwrap();
let string = "2000-02-02
1987-02-02
1000-sd-65
2100-12-87
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}