import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(The reason for this is\\s*:\\s*)(\\S*(?:\\s(?!\\s*Kind regards)\\S+)*)(\\s*Kind regards)";
final String string = "The reason for this is: 111111111\n"
+ "2222\n"
+ "3333\n"
+ "ddddddddd\n"
+ "Kind regards.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}