const regex = /(The reason for this is\s*:\s*)(\S*(?:\s(?!\s*Kind regards)\S+)*)(\s*Kind regards)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(The reason for this is\\s*:\\s*)(\\S*(?:\\s(?!\\s*Kind regards)\\S+)*)(\\s*Kind regards)', '')
const str = `The reason for this is: 111111111
2222
3333
ddddddddd
Kind regards.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}