package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([02][1-9]|2[AB]|[1345678][0-9]|9[012345]|97[12346])$`)
var str = `60
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}