import re
regex = re.compile(r"^([02][1-9]|2[AB]|[1345678][0-9]|9[012345]|97[12346])$")
test_str = ("60\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")