$re = '/^([02][1-9]|2[AB]|[1345678][0-9]|9[012345]|97[12346])$/';
$str = '60
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);