const regex = /^([02][1-9]|2[AB]|[1345678][0-9]|9[012345]|97[12346])$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([02][1-9]|2[AB]|[1345678][0-9]|9[012345]|97[12346])$', '')
const str = `60
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}