#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""s":\[".+",*]"
Local $sString = "[{"code":1,"pos":0,"row":0,"col":0,"len":3,"word":"gae","s":["gay","game","age","gee","gage"]}]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")