use strict;
my $str = '[{"code":1,"pos":0,"row":0,"col":0,"len":3,"word":"gae","s":["gay","game","age","gee","gage"]}]';
my $regex = qr/"s":\[".+",*]/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}