package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"s":\[".+",*]`)
var str = `[{"code":1,"pos":0,"row":0,"col":0,"len":3,"word":"gae","s":["gay","game","age","gee","gage"]}]`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}