#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!0{2,})\d+(?:\.\d+)?$"
Local $sString = "0.1" & @CRLF & _
"11.04" & @CRLF & _
"0129" & @CRLF & _
"The numbers that should not be allowed are " & @CRLF & _
".9" & @CRLF & _
"0009999.33" & @CRLF & _
"0007"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")